Jump to content
Sign in to follow this  
Inherited2006Taurus

Remote Climate Control (RCC)

Recommended Posts

I'm in Illinois and am looking for a 2000-2003 Taurus RCC.  I'm converting over to EATC and ran into the same problem others had.  My RCC is from a 2004 Sable and does not directly control the A/C on demand signal with a discrete output.  Price is negotiable...  Or maybe you could point me to a junkyard that you know has an EATC equipped Taurus/Sable from that gen.  Will travel to get it.

Thanks

 

 

Edited by Inherited2006Taurus
Errors

Share this post


Link to post
Share on other sites
On 8/12/2020 at 7:09 PM, Inherited2006Taurus said:

I'm in Illinois and am looking for a 2000-2003 Taurus RCC.  I'm converting over to EATC and ran into the same problem others had.  My RCC is from a 2004 Sable and does not directly control the A/C on demand signal with a discrete output.  Price is negotiable...  Or maybe you could point me to a junkyard that you know has an EATC equipped Taurus/Sable from that gen.  Will travel to get it.

Thanks

 

 

Did you get the blower, control box, and module for vacuum and such?

-chart-

Share this post


Link to post
Share on other sites

Thanks for asking.  I got all that with the RCC from a 2004.  Yes, I got it all again from the 2003.  I decided to just try just installing the RCC (from 2003) with the other 2004 parts and it all works together.  Thanks, taurusKev!.  The 2003 RCC has the A/C on-demand output (pin 13) which is not duplicated in the 2004.  So does anyone know how the 2004 RCC communicates to turn the A/C on.  A friend thought the PCM might have to be reprogrammed

I used a metra kit and put a double din touchscreen in also which was the main reason to go to the EATC.  Now my radio has crapped out, its always something.  Changed the connector and harness out for the radio and it worked for a few minutes then quit again.  It's getting power and ground is good, but nothing happens on the screen.  It's the first Pioneer I've had break in many years of installing them. Last year I took it to a Pioneer repair place west of Chicago, and they said it was fine, check my connector.  So that's why I put a new harness in, but it seems the problem is in the radio

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...