Jump to content
Sign in to follow this  
05sablepgh

A/C issue need help

Recommended Posts

I've had this issue since I purchased the car. Had my whole system redone and recharged 2 years ago. My ac will not stay on. I thought it was a climate control issue. When I bump the radio around the dash the compressor will turn on then at times turn off and I have to bump the dash around the radio again. I replaced my factory radio (tape deck/climate/cd controls Mach audio) with one from a car with 100k less. Didn't fix the issue. Does anyone have any ideas what could be going on? Thank you.

Share this post


Link to post
Share on other sites

It sounds like a loose wire at the ICP. Pull the ICP and check integrity of the connectors and the wires in the connectors

Share this post


Link to post
Share on other sites
On 5/10/2020 at 2:43 PM, rdh2 said:

It sounds like a loose wire at the ICP. Pull the ICP and check integrity of the connectors and the wires in the connectors

Icp?

Share this post


Link to post
Share on other sites
10 minutes ago, Westy48 said:

Icp?

Never mind, was having a brain fart 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...