Jump to content
Sign in to follow this  
Rollinheavy65

Rough idle, start then stalling, fluctuating idle, please help

Recommended Posts

Okay so I'm not sure where to go from here, but my car runs great when its just driving, start to brake or come to a stop then it starts to act up. On start up sometimes it will be fine, other times it runs for a few seconds then dies, this will happen repeatedly, very frustrating it is. So i cleaned the MAF, IAC, throttle body, did plugs,. So next I'm thinking pcv valve, wires, and ? Anything else any tips would be useful, thank you guys!

Share this post


Link to post
Share on other sites

Sounds like the PCV to me. For some reason Ford designs their engines to pull most of their air through the crankcase whenever the throttle is closed. Any leaks in the PCV system (hoses or plastic connections, maybe a bad valve) cause the engine to run poorly.

My last Taurus would cold start rather hard in warm or hot weather. Stumble and miss for the first few seconds. In the middle of winter when it was very cold I would have to hold the accelerator down a bit or the engine would stall right away. Never did get it figured out and my PCV system was fine.

Edited by Angrod

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...