Jump to content
Devin

What Have You Done To Your Bull Lately?

Recommended Posts

Share this post


Link to post
Share on other sites
Started driving it again after blown axle seal got replaced.

I gotta get more recent pics. i think ill snap some today right before work.

but for now:

10354995_614265968671919_429844770300144

Yeah buddy.

oh, I'm still alive BTW

$had3 :ford::merc::Shady_J:

Nice I'm liking the flat black on it B)

Share this post


Link to post
Share on other sites

More current pix:

 

10352556_618248181607031_128958962841550

 

10463075_618248274940355_311031133506000

 

 

$had3 :ford::merc::Shady_J:

Share this post


Link to post
Share on other sites

WheelPaint14_zps1d4c39aa.jpg

 

Today's wheel project. This is a $20 JY wheel/tire, reasonable tire, wheel has some bad coating on the flat surfaces. I sanded all the front surface with orbital sander, 80G and 150G. Scrubbed the other surfaces with abrasive and washed it.

Used Dupli-Color High Performance wheel coating. And clearcoate over.

OK, I took the best tire from the JY, not the best wheel surface. The $20 is total, $10 for wheel, $10 core. So, this one completes my spare set of 4, and two cars with the same wheel. "Got Spares".

 

Ready for some sun cure.

 

Went to Autozone for another can. Well, they now have some Dupli-color and some brand X. No duplicolor wheel paint. Brand X colors but not silver. Would not want gray or red and such.

 

Went to Advance guy there showed me where they kept paint. He never heard of wheel paint. But they did have some and he could not see it so I found it. He said what color and I said silver. Well "they do not have that". I asked what was supposed to be in the empty slot in the dispaly. He did not know. I read the label and that is what was in the empty slot. I asked when they would get more. He said, maybe next Wed. Oh well, lots of cans of stuff but what might be useful, they are out. Maybe there is a reason why they have a full rack of brown wheel paint, and no silver.  Duhhhhh.

 

This wheel goes on the wagon when it is cured and the wheel weight back on. (of course I put a marker where it goes) :notworthy:

 

-chart-

Share this post


Link to post
Share on other sites

Yea Chart AutoZone has VHT stuff and Advance has the Dupli-color stuff.  Both stores have both brands but they also don't carry the same products.  

Share this post


Link to post
Share on other sites

Well as several of you may already know the SHO is having severe transmission issues, I have had absolutely no time to deal with it so it has spent the last week sitting in the garage.  I did have time for a quick spin yesterday, I made it a block down the road at which the transmission slipped upon even the slightest throttle pressure, so I turned around and put it back in the garage.  I should have time tomorrow to get something lined up for a professional to take a look at it and get their opinion.  I've had several days to calm my mind and am no longer upset with the situation.  What ever needs to be done will be completed to get the car back to proper running order, as well as other issues that I might as well take care of so I can actually drive the car how I want without worrying about something going wrong.

  • Like 1

Share this post


Link to post
Share on other sites

*sigh of relief*

Share this post


Link to post
Share on other sites

Swap it for a Manual Transmission.

Manual Transmissions :wub:

Share this post


Link to post
Share on other sites

Does Eric have anything that could help you out Trace?  What mileage is the car at these days?

 

----


So Another evening of work and the 2000 is about ready to finally come out of the garage. I have replaced…
All AC lines (liquid line w/orfice, accumulator w/hose, manifold hose etc) were Motorcraft, condenser (Motorcraft), and a Denso AC compressor (new).

Also put in a new radiator as the old one would leak in winter (Spectra Made in Canada). Installed a new Motorcraft thermostat because the old one wasn't letting the car go over 178-180F in normal operation, running too cool. All that stuff is bolted in.

I also installed a SHO Gen 2 ATX cooler up front in line with the radiator hoses. 

All that's left tmrw is to change the oil, fill the PS fluid reservoir up (had to disconnect hose at cooler), fill up car with coolant, then start and run the car - get the air out of the PS fluid and cooler. Check for leaks. Check ATF level once temp gets hot enough. If its leak free and running good, then I'll put the bumper cover back on and on Saturday or Sunday I'll charge the AC system up :-) 

I have been driving the Colony Park (91) a lot lately. It needs to be taken off the road so I can swap power trains with the 87 (which has recent jasper parts :-) ).
__________________

Share this post


Link to post
Share on other sites

SES light returned in the '99 SE. P1744. It doesn't appear to be a serious issue yet. Possibly a dirty connector, failing TCC solenoid, or failing TC. My friend is still renting the vehicle for the summer and she's happy as long as it gets her to work and the AC blows cold. Front tires are almost due for replacement. The heat has caused the dash warp to get worse.

Share this post


Link to post
Share on other sites

SableFix14_zps7b1eafe6.jpg

 

Dogleg just painted, no clearcoat yet. Wheel was JY $20 decent tire, pealing wheel. Cleaned, sanded, painted, clearcoat.

Dogleg is bondo and glass cloth, minimum 2 layers cloth, lip is 3 layers as it was gone.

Maybe get this through one more winter.

When I find more wheel coating, I will cycle through the other wheels.

 

-chart-

Share this post


Link to post
Share on other sites

Heard that my cousin blew the transmission in his Gen V.

 

May have to sell him a RWD car that can handle him :icon_twisted:  (Or at least, one that's lost enough horses that the remaining ones can't hurt the rest of the driveline... :ph34r: )

Share this post


Link to post
Share on other sites

 

Does Eric have anything that could help you out Trace?  What mileage is the car at these days?

 

 

 

 

I do need some new SHO chrome wheels as I found out this evening one of wheels on the 2002 is screwed up.  They were able to balance it out but the rim must be bent or something. 

 

And I believe the SHO is just a tad over 159,000 miles.  That will be changing fast with this used trans going in, gotta make sure it doesn't have any issues during the warranty period.

  • Like 1

Share this post


Link to post
Share on other sites

I have 1 or 2 SHO Chrome wheels in my garage…1 has curb rash I know.  Shall I check?

Share this post


Link to post
Share on other sites

I only need 1 in good shape, I know it's hard to sell just 1 rim and not pairs.

Share this post


Link to post
Share on other sites

Well the 1 I have in the garage has curb rash on the wheel (it's a southern one from a 98 SHO), and has a gash in the sidewall of the tire.  Am going to hang onto it in case I bend a wheel.  Don't see any spares, I guess I sold what I had to Eric - could have gotten you a couple from a 97 SHO out by Zach in Augusta, GA.

 

Today I filled up the car with fluids after changing the oil.  Michakaveli came over and helped while I was firing it up.  Car seems to be running AOK.  Nice and quiet.  Amazing how nicely the motor purrs at nearly 200K original miles.  No smoke.  No knocking.  No rattling.  Just the clicking fuel injectors.  I will change out the PCV at the next oil change since it'll have been 85-90K miles.  Got the cooling system bled, transmission level set after adding cooler, got the power steering system bled.  After retightening some hose clamps, don't see any new leaks.  Will verify again tomorrow, and if all good, will reinstall bumper cover, wheel well shields, under carriage splash/air dam, grill, and headlights.  It does weep oil in spots but meh let it.

Share this post


Link to post
Share on other sites

Recently I changed the RCA cable that I use to connect my ZuneHD. The old one was crackling really bad after a couple years of use. The stereo now sounds normal again.

Share this post


Link to post
Share on other sites

I just got home from florida and cleaned my car. I haven't vacuumed it in months. Most of the crap was caught in the weather tech floor mats which I clean about once every 2-3 weeks. But it was filthy and is now very clean! Need to wax... Maybe this week.

Share this post


Link to post
Share on other sites

Got the SHO across town and delivered to the site for transmission work to begin at some point next week. It was mostly highway driving so not many opportunities to slip, but it did once under the lightest throttle ever, drove like a granny at every intersection. Almost killed 2 guys on a motorcycle on the way there as well, idiots pulled too far out of a turn lane and were directly in line with me for a head on collision at 50mph.

Share this post


Link to post
Share on other sites

OK folks, I acquired this item today that can be put to good use in one of my cars. :ph34r:

The question is, what exactly is it? ;) I'm kind of curious who here will recognize the purpose for this hefty piece of steel.

Share this post


Link to post
Share on other sites

OK folks, I acquired this item today that can be put to good use in one of my cars. :ph34r:

The question is, what exactly is it? ;) I'm kind of curious who here will recognize the purpose for this hefty piece of steel.

attachicon.gifimage.jpg

attachicon.gifimage.jpg

attachicon.gifimage.jpg

 

CD changer mounting bracket of some sort?

Share this post


Link to post
Share on other sites

Mounting a gauge on a dashboard without drilling holes into the dash material?

 

Went to a friends to put the car on a vacuum for the AC system.  Huge leak.  Dang.. it's all new but the evap core, what the heck could it be.

 

After plugging lines up, and running test on just the evap core...it is in fact the evap core.  Great.  Guess who gets to take the dash and HVAC box out?

Share this post


Link to post
Share on other sites

OK folks, I acquired this item today that can be put to good use in one of my cars. :ph34r:

The question is, what exactly is it? ;) I'm kind of curious who here will recognize the purpose for this hefty piece of steel.

attachicon.gifimage.jpg

attachicon.gifimage.jpg

attachicon.gifimage.jpg

I know what it is :lol::rofl:

Share this post


Link to post
Share on other sites

I can't go back to a sedan due to this:

IMG_2810.jpg

IMG_2811.jpg

IMG_2812.jpg

Long Live the Station Wagon :wub:

  • Like 3

Share this post


Link to post
Share on other sites

*SPROOOIIING*

Ya popped a spring or something. :ph34r:

:P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×