Jump to content
Sign in to follow this  
REDTRUCKCHASER

ABS LIGHT CAME ON

Recommended Posts

First time I've seen this come on other than at startup.  I know it could be anything from a bad bulb to a bad wire or solenoid.   😲

I pulled off the road. Stopped the car. Waited about 5 mins.  Started up as usual with the lights flashing as they should at startup.  Drove home and no ABS lights came on.

Bull is going into the shop on Thursday for some other work and I'll have them  look at it.  

I'm wondering if there's anything I can do before then to check this out.  

Share this post


Link to post
Share on other sites

Had an intermittent ABS light on the '97 a few years back. My issue was a dirty wheel speed sensor. Cleaned it off with some brake clean and haven't had that issue in several years.

It may have set a code that possibly can be read on the scan tools some auto part store use. Worth a shot to see if anything comes up.

Share this post


Link to post
Share on other sites

Thanks Zach.  Shop will check out sensor when I take it in on Friday.  So far it's driving OK, and light has only come on once more. Still, I want to get it checked out and fixed before winter comes. 

Share this post


Link to post
Share on other sites

All is well. Historic ABS sensor code for a new ABS module. Shop says not to do anything unless it comes up again. They cleared the code, car drives just fine. 

I did some back road sudden stops to see if anything felt odd,but it didn't.  She still stops on a dime ! 

Share this post


Link to post
Share on other sites

I spoke too soon. Light is coming on again.😢

When I'm back from vacation, am going to have this fixed. Ford part is obsolete. Unless I can find it from one of my Ford dealers, will go aftermarket and have it fixed. I'm not comfortable riding around not knowing if the light is on because of bad sensor, or if my brakes really do have a problem. 

Share this post


Link to post
Share on other sites

I wouldn’t be especially worried, even if the ABS isn’t functioning your hydraulic brakes will still work. It’s just a little more old school in the mean time. 

Share this post


Link to post
Share on other sites

Now the red brake light has come on as well. I'm not happy about lights coming on that shouldn't !  Must fix !

Meanwhile, will continue to rely on hydraulic brakes.  They've never let me know. 

Share this post


Link to post
Share on other sites

Red light is either parking brake not fully released or low brake fluid.

 

I know on the V8 SHO's the low fluid sensor is a lying piece of junk.

 

Do a visual on the fluid level and look for puddles under the car before driving off in it after the red light activates, please.

Share this post


Link to post
Share on other sites

Just had all the fluids changed out. Brake fluid is where it should be.  Parking brake is released fully.  

The brake light comes on intermittently when the ABS light comes on.  It will stay on for 15-20 mins, sometimes then it goes off. Other times it stays on.

When I'm back from vacation will haul it back to the shop. Ka-ching ! 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...