Jump to content

96 taugus wagon. shift cable broken


Recommended Posts

hello.

 

so, the other day my wife was driving her car. put it in reverse to back out of the spot, worked fine, went to put it in drive and nothing(still reverse i assume) put it in park, which it went into. couldnt get it into gear. calls me, i get there and see the linkage is connected to the shifter. put it in drive and pop the hood. manually switched the trans and about ran myself over! used shifter to out it back in park. so, my findings seem to point to a broken cable. im having trouble finding a correct part number. i found one on amazon that is yf1z-7e395-ba. 104 bucks. went to the ford dealer(could have it in the same time as amazon) for 140. how an i fond the correct number(none of the parts stores had the part even in the system

Link to post
Share on other sites

If the shifter is by the steering wheel, the part number is YF1Z-7E395-BA. It’s the same shifter from 1996-2000 models. Could get one used as well...

Link to post
Share on other sites
3 hours ago, Bull Geek said:

If the shifter is by the steering wheel, the part number is YF1Z-7E395-BA. It’s the same shifter from 1996-2000 models. Could get one used as well...

yes, ive got a column shifter. does me having the ax4n and 3.0 vulcan(OHV, not DOHC) matter?

 

i prefer oe new parts. things got 210k on the clock, will likely go another 50-100k with me.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...