Jump to content

Recommended Posts

Good afternoon my name is Clarence and am very happy to be a part of this club. I have a 2006 taurus sel 3.0 that just dos,ent want to idle.Rest your foot gently on the accelerator and purrs like a kitten ,remove your foot and the car dies right out. I have changed the maf sensor,dpfe sensor and no change. can hear massive air suction when pressing the accelerator up and down, sounds like its coming from the right side of the manifold (drivers side) towards the fire-wall.definetly sucking air some where! And im running out of money chasing this gremlin any ideas or help will greatly be appreciated.

Link to post
Share on other sites

Welcome to TSOC! I'm sure somebody will be able to chime in and help you with this.

Sounds like you may have a vacuum leak! You may want to get it smoke tested and look for leaks.

  • Like 1
Link to post
Share on other sites

 Got the same issue going on with my 2006 Taurus sel 3.0 still won,t idle. Will try smoke test ,plus I got a mech. coming over this evening , hope he can locate the leak and I can get back on the road. Thanks for the replies.

Link to post
Share on other sites

Yankee,

Please post replies in your existing thread. Making a new thread means we don't know the context of your question. I've merged them now. You can reply at the bottom of the page.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...