Jump to content
Brian_05_SEL

Scarlett: 1987 Mercury Sable (A Low Mileage Survivor)

Recommended Posts

Honestly - how bad is the paint? Is the clear starting to fail on horizontal surfaces?  I didn't think it was too bad but it's been a few years.

if you repaint - I'd stick with original color because then your jams will all be the correct color already. That red isn't a bright vibrant - seemed closer to a darker red with nice metallic flake.  Black of course will show every speck of dirt!

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Bull Geek said:

Honestly - how bad is the paint? Is the clear starting to fail on horizontal surfaces?  I didn't think it was too bad but it's been a few years.

if you repaint - I'd stick with original color because then your jams will all be the correct color already. That red isn't a bright vibrant - seemed closer to a darker red with nice metallic flake.  Black of course will show every speck of dirt!

 

It should be in good shape since Chris did his magic on the clearcoated/painted surfaces in 2014. "Bright Red Metallic" is definitely a darker shade of that color, like a Gen 4 in Merlot, and IMO the car should remain that same color. 

Share this post


Link to post
Share on other sites

Its in relatively good shape still. However the rear quarter panels are starting to lose bottom trim due to rust beginning to weaken the panel. Its either attack the issue now or wait and possibly create more work later on. Were the panels coated without the side trim? At minimum the trim/bumpers need work due to fading, cracks, and scratches.

The door jam issue is fine. We know how to professionally paint and have all of the equipment to do so along with complete body restoration. We have done a few other vehicles before so it would be completely dismantled and done top to bottom. I want this car to look showroom new. Its so very very rare to see these in top notch shape and this is an excellent, well preserved car to accomplish this. But, time is beginning to take its toll. After 30 years on the road there are various other scratches and dents I'd like to see removed.

I agree with red, black, and silver being best choices to match interior. Either it will stay the same color or I was thinking along the lines of this...

 

b725d0d5dca74f538ad82a4150925c92.jpg

  • Like 1

Share this post


Link to post
Share on other sites

It was originally painted red with a black pinstripe from the factory, so that's pretty much the exact opposite. Wouldn't look bad. 

Share this post


Link to post
Share on other sites

Well, pretty sure the EIC is shot. I cant even get it into self test mode. We've tested every diode, connection, and what have you and its all good. Strange.

So, I had to order a used one. Hopefully there are no further problems. If it works, great! If not....back to the drawing board. It would be SO nice to know what speed I'm going :rolleyes:

 

I did manage to snag all NOS rear glass panels and tail lights as well!

Share this post


Link to post
Share on other sites

What about that spare 1986 Taurus LX cluster that was in the trunkload of spare parts I sent with it? 

Share this post


Link to post
Share on other sites

Converting to analog would be our next option if the digital replacement also fails.

Share this post


Link to post
Share on other sites

Replaced the EIC and works like a dream. The gas/temp gauge also works again. Not sure what the issue was, but when the shop manual says "replace EIC" after every complication listed there must be no fix for these once they go out. Only problem is, I lost the true mileage. :angry: Once it started to fail it reset the car's mileage to only 56...hah.

20292823_10154854222717473_169532061467424094_n.jpg

  • Like 1

Share this post


Link to post
Share on other sites

I wonder if you can do some kind of reprogramming of the EIC?

any visible issues on circuit board or the copper lined plastic panel on the back?

Share this post


Link to post
Share on other sites

Its strange. We tested all the circuits and components. Everything was correct and all had correct amperage draw. Tested for grounding etc. Nothing. The shop manual had an extensive troubleshooting list on these all of which resulted in "Replace EIC" if everything else checks okay.

The picture shows one of the many odd behaviors it had. It would consistently blink, ghost, beep, display codes, varying speeds, shut completely off. Sometimes it would operate but without any lights. Very erratic.

 

 

20376052_10154854531722473_2253419177204412020_n.jpg

  • Like 1

Share this post


Link to post
Share on other sites

 

  • Like 1

Share this post


Link to post
Share on other sites

Glad that the cluster is working again. 

Share this post


Link to post
Share on other sites

Update as of 2019.

Our original intent to have the entire car painted is dead. I ended up purchasing a 1990 with no dents or rust and that is the perfect candidate for complete overhaul. Scarlet is, of course, still running the roads. Last year I took her on a nice long trip into the upper peninsula to Ontonagon, MI. About an 8 hour drive and it was smooth sailing the entire trip for 2 weeks. Was nice to have it out and about.

This last year I revamped the basket wheels and had to repaint the bumper and trim. Too much had begun to flake off and was down to bare plastic. So, with the new refreshed look she made her way through the 4th of July parade!

67155070_10156659313572473_3363098171751268352_n.jpg

67207848_10156659313757473_6899840741703417856_n.jpg

67275537_10156659313537473_4865201707228856320_n.jpg

67366247_10156659313802473_7553861770079633408_n.jpg

67456564_10156659313712473_6099869779647004672_n.jpg

Edited by Sablekid
  • Like 3

Share this post


Link to post
Share on other sites

Scarlett is looking fantastic. How many miles on her now? 

Edited by Brian_05_SEL

Share this post


Link to post
Share on other sites

I dont know anymore :(

When the dash began to act up it erased its memory. If i had to guess, its probably sitting around 61K

 

By the way. Do you know if this ever was changed over to R-134? Planning on taking this for a week when we vacation on Lake Michigan and we have a friend that can recharge AC. Would be nice to have AC in this again!

Share this post


Link to post
Share on other sites
9 hours ago, Sablekid said:

I dont know anymore :(

When the dash began to act up it erased its memory. If i had to guess, its probably sitting around 61K

 

By the way. Do you know if this ever was changed over to R-134? Planning on taking this for a week when we vacation on Lake Michigan and we have a friend that can recharge AC. Would be nice to have AC in this again!

 

To my knowledge, it was already converted to R-134 before I purchased it. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...