• Announcements

    • Sean T.

      Having trouble logging in after the update?   04/25/16

      After the forum update, you need to use your displayed name as your login. Your password should remain the same. If you are still having trouble, please e-mail Sean at TaurusOwners@gmail.com and he can reset your password.
    • Sean T.

      Help Support TSOC by Making a Donation!   01/29/17

      TSOC is funded by donations only. The operating expenses for TSOC are about $320 annually for hosting, domains, and IP Board license renewals. Support from our members is greatly appreciated! As always, we are grateful for ANY and ALL donations! From $1.00 to $100.00, anything you give will support the forums and community experience. At any time, you are free to make a standard donation towards our operating expenses. Surplus funds will stay with the forum for next year, so even if it appears we have enough cash on hand, we're always in need of donations! When you make a donation towards our operating expenses, your membership will automatically upgrade based on your donation amount. (Please see the link below for more info)     Click HERE to learn more about our membership levels!  
    • Sean T.

      !!! *** Known Issue for New Member Sign-Up *** !!!   04/20/17

      It has been brought to our attention that new members are unable to sign up. Producing an error code EX1364. We are aware of the issue and are working to resolve it. In the mean time, if you encounter this error, please send a message using the "Contact Us" link at the bottom of the page, and we will contact you when it has been resolved.
Brian_05_SEL

Scarlett: 1987 Mercury Sable (A Low Mileage Survivor)

757 posts in this topic

Honestly - how bad is the paint? Is the clear starting to fail on horizontal surfaces?  I didn't think it was too bad but it's been a few years.

if you repaint - I'd stick with original color because then your jams will all be the correct color already. That red isn't a bright vibrant - seemed closer to a darker red with nice metallic flake.  Black of course will show every speck of dirt!

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, Bull Geek said:

Honestly - how bad is the paint? Is the clear starting to fail on horizontal surfaces?  I didn't think it was too bad but it's been a few years.

if you repaint - I'd stick with original color because then your jams will all be the correct color already. That red isn't a bright vibrant - seemed closer to a darker red with nice metallic flake.  Black of course will show every speck of dirt!

 

It should be in good shape since Chris did his magic on the clearcoated/painted surfaces in 2014. "Bright Red Metallic" is definitely a darker shade of that color, like a Gen 4 in Merlot, and IMO the car should remain that same color. 

Share this post


Link to post
Share on other sites

Its in relatively good shape still. However the rear quarter panels are starting to lose bottom trim due to rust beginning to weaken the panel. Its either attack the issue now or wait and possibly create more work later on. Were the panels coated without the side trim? At minimum the trim/bumpers need work due to fading, cracks, and scratches.

The door jam issue is fine. We know how to professionally paint and have all of the equipment to do so along with complete body restoration. We have done a few other vehicles before so it would be completely dismantled and done top to bottom. I want this car to look showroom new. Its so very very rare to see these in top notch shape and this is an excellent, well preserved car to accomplish this. But, time is beginning to take its toll. After 30 years on the road there are various other scratches and dents I'd like to see removed.

I agree with red, black, and silver being best choices to match interior. Either it will stay the same color or I was thinking along the lines of this...

 

b725d0d5dca74f538ad82a4150925c92.jpg

1 person likes this

Share this post


Link to post
Share on other sites

It was originally painted red with a black pinstripe from the factory, so that's pretty much the exact opposite. Wouldn't look bad. 

Share this post


Link to post
Share on other sites

Well, pretty sure the EIC is shot. I cant even get it into self test mode. We've tested every diode, connection, and what have you and its all good. Strange.

So, I had to order a used one. Hopefully there are no further problems. If it works, great! If not....back to the drawing board. It would be SO nice to know what speed I'm going :rolleyes:

 

I did manage to snag all NOS rear glass panels and tail lights as well!

Share this post


Link to post
Share on other sites

What about that spare 1986 Taurus LX cluster that was in the trunkload of spare parts I sent with it? 

Share this post


Link to post
Share on other sites

Converting to analog would be our next option if the digital replacement also fails.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.