Jump to content

Shade Got A Sho! Finally!


Recommended Posts

  • Replies 59
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

So, when's the engine revving contest?

A clean shop/garage is the sign of a sick mind. -chart-

Well. It has FINALLY happened!! yall know Ive been pissing and moaning about getting a SHO. Me and Mr. Vash Made that happen. 300 some miles, a Uhaul Trailer and some jiving at the bank has landed me

Well she's more or less just been sitting around here for now, waiting to be hauled in. I have a week and a half more of Basic Electrical before i can bring her in, according to the teacher.

thus to show her i still love her, Ive been buying parts for her including:

  • AVS Vent Visors for the windows
  • a K&N Air filter
  • a Parts Master fuel filter
  • Autolite Iridium Spark Plugs, part number xp104
  • a Dorman brand new SAI pump, or Smog pump, as my store knows it as

Other than that, she's just waiting...

Pics up when i get to it. kinda busy tonight.

$had3 :ford::merc:others-261.gif

Link to post
Share on other sites

Well she's more or less just been sitting around here for now, waiting to be hauled in. I have a week and a half more of Basic Electrical before i can bring her in, according to the teacher.

thus to show her i still love her, Ive been buying parts for her including:

  • AVS Vent Visors for the windows
  • a K&N Air filter
  • a Parts Master fuel filter
  • Autolite Iridium Spark Plugs, part number xp104
  • a Dorman brand new SAI pump, or Smog pump, as my store knows it as

Other than that, she's just waiting...

Pics up when i get to it. kinda busy tonight.

$had3 :ford::merc:others-261.gif

As to AutoLite

See pic of new ones, which I returned and for obvious reasons.

And the ones that caused electric radiation that messed up the engine operations but did not misfire.

Cost me $330 to get that one traced. And I thought a plug would misfire and set a code. No misfire, just messed up the spark advance.

So I will not be using Autolite although most should be OK but I would inspect really carefully new ones.

Just sharing my exp.

-chart-

Link to post
Share on other sites

I have some lame WAI K&N setup on my V8 that needs to go. Did you get a panel K&N?

Yep! part number 33-2017 i believe. and a WAI? i may be interested in it... lets talk shall we?

As to AutoLite

See pic of new ones, which I returned and for obvious reasons.

And the ones that caused electric radiation that messed up the engine operations but did not misfire.

Cost me $330 to get that one traced. And I thought a plug would misfire and set a code. No misfire, just messed up the spark advance.

So I will not be using Autolite although most should be OK but I would inspect really carefully new ones.

Just sharing my exp.

-chart-

I will keep it in mind, and the tip is much appreciated. ill triple check them

It's going to be wicked, :ph34r:

how you figure? haha

$had3 :ford::merc:others-261.gif

Link to post
Share on other sites
  • 4 weeks later...

THE ENGINE HAS BEEN PURCHASED

I shelled out 530 for a 98 cam failure, and have been stripping it of its cam failed parts, as well as accessories. anyone need a complete set of intake runners, or a throttle body, or IAC? lol got a table of parts here!

Pics will get posted when i find my camera.

$had3 :ford::merc::Shady_J:

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...