Jump to content
mwt

99 Taurus Tach And Speedometer Aren't Working

Recommended Posts

I used to know all this stuff but I haven't done any major work on my Taurus' in years.

Anyway, we are giving the 99 to a family that needs a work car.

I haven't started it in I don't know how long.

I put it on jackstands a couple of years ago with the intention of pulling the struts and hogging out the holes so I could get it aligned.

I had noticed that sometimes the AC would quit working and the car would have to be restarted for it to start working again.

Anyway, I started it last weekend and there are two things.

1. the tach and speedo do not work.

2. the AC doesn't even kick in.

I had pulled the oil sending unit to try on my duratec before I realized they were different sending units. I had to pull a water hose to get to it.

So I put those back on and started the car right up.

I gave it a cursory once over to make sure mice hadn't chewed any wires and I double checked to make sure everything was plugged in.

Any ideas where to start?

Luke, I am expecting you to kick in here and tell me how to fix all this crap in five minutes.

Mike

:dunno:

Edited by mwt

Share this post


Link to post
Share on other sites

I checked all the fuses. They were good.

Then I went under the hood and disconnected and reconnected every connector.

Now everything works and the AC is blowing cold air.

:WOOT:

Mike

Share this post


Link to post
Share on other sites

Musta been something loose or a contact a little corroded. Gotta love a free fix, eh?

Share this post


Link to post
Share on other sites

Go under the hood and disconnect and reconnect every connector.

biggrin.gif

Share this post


Link to post
Share on other sites

Well that's an easy enough fix. The beast lives...sry i was of no help through txt.

Share this post


Link to post
Share on other sites

Go under the hood and disconnect and reconnect every connector.

biggrin.gif

I got a full tank of gas in the corolla. I will come out there and beat you to death.

Mike

:rolleyes:

Share this post


Link to post
Share on other sites

Well that's an easy enough fix. The beast lives...sry i was of no help through txt.

. I damn near got in a high speed collision because I was texting and driving.

I aint doing that anymore.

Mike

:blink:

Edited by mwt

Share this post


Link to post
Share on other sites

. I damn near got in a high speed collision because I was texting and driving.

I aint doing that anymore.

Mike

:blink:

We don't need a Well, s**t 4.

Share this post


Link to post
Share on other sites

. I damn near got in a high speed collision because I was texting and driving.

I aint doing that anymore.

Mike

:blink:

pat.gif man...

At a traffic light today, looked over...father and daughter were both txting away on their phones in the Dad's Bimmer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...