Jump to content

Recommended Posts

Well about (2) years ago, I had replaced the worn out factory composite front end links. They had some play on both sides so I replced them w/ the metal Moog end links. I just started hearing the "popping" noise yesterday. I replaced them That cured the problem then. I'll check it out fully this weekend. I probably should check out the front struts too. I installed SHO rear springs and new struts about 3 or 4 years ago, so possible the front struts may be nearing replacement. Shes got 89k miles on her now.

Link to post
Share on other sites

Chester needs new links too. Nick is gonna' come over and take care of that for me. LOL!

Haha just holla when u is ready!

BTW...for what its worth, my Ingalls front end links apparently had some sort of issue. The Front passenger one to be specific. Something with the joint itself being loose. It was trashed after 10K miles, and had been making racket for the past 7-8 of it, lol. The sealed, metal endlinks from Deeza are apparently some of the best you can buy (popular company in Europe, on the rise here in US). Especially for people that drive on crummy roads, they have a unique design. Will be happy to post a PDF of their design & info if interested.

Link to post
Share on other sites

Haha just holla when u is ready!

BTW...for what its worth, my Ingalls front end links apparently had some sort of issue. The Front passenger one to be specific. Something with the joint itself being loose. It was trashed after 10K miles, and had been making racket for the past 7-8 of it, lol. The sealed, metal endlinks from Deeza are apparently some of the best you can buy (popular company in Europe, on the rise here in US). Especially for people that drive on crummy roads, they have a unique design. Will be happy to post a PDF of their design & info if interested.

I would be interested in seeing those Nick. Both my Ingalls show wear (some play on both sides). I think they only had about 10-12k miles on them too.

Link to post
Share on other sites

Sorry to borrow this thread, but just wanted you to take a quick look of the picture I posted in this thread:

http://www.taurusowners.com/index.php?/topic/264-please-help-me-isolate-rear-suspension-noises/

I bought both ingalls rear link and 26mm swaybar from you.Just wonder have you ever seem the endlink bushings popping out like this before? I'd appreciate your insight, thanks!

We would like to see about getting back so we can see what is going on.

Link to post
Share on other sites

I think it's nearing that time for me to replace my endlinks as well. I've got 55K on the originals, and I'm starting to hear that infamous popping noise.

Link to post
Share on other sites

Sorry to borrow this thread, but just wanted you to take a quick look of the picture I posted in this thread:

http://www.taurusown...pension-noises/

I bought both ingalls rear link and 26mm swaybar from you.Just wonder have you ever seem the endlink bushings popping out like this before? I'd appreciate your insight, thanks!

It looks like you have the bushing in backwards. The knob needs to go into the sway bar.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...