• Announcements

    • Sean T.

      Having trouble logging in after the update?   04/25/16

      After the forum update, you need to use your displayed name as your login. Your password should remain the same. If you are still having trouble, please e-mail Sean at [email protected] and he can reset your password.
    • Sean T.

      Help Support TSOC by Making a Donation!   01/29/17

      TSOC is funded by donations only. The operating expenses for TSOC are about $320 annually for hosting, domains, and IP Board license renewals. Support from our members is greatly appreciated! As always, we are grateful for ANY and ALL donations! From $1.00 to $100.00, anything you give will support the forums and community experience. At any time, you are free to make a standard donation towards our operating expenses. Surplus funds will stay with the forum for next year, so even if it appears we have enough cash on hand, we're always in need of donations! When you make a donation towards our operating expenses, your membership will automatically upgrade based on your donation amount. (Please see the link below for more info)     Click HERE to learn more about our membership levels!  
    • Sean T.

      !!! *** Known Issue for New Member Sign-Up *** !!!   04/20/17

      It has been brought to our attention that new members are unable to sign up. Producing an error code EX1364. We are aware of the issue and are working to resolve it. In the mean time, if you encounter this error, please send a message using the "Contact Us" link at the bottom of the page, and we will contact you when it has been resolved.
NORM_K7NCR

Gas Cap/check Engine Light On

3 posts in this topic

All right, maybe this has been discussed here before, but as a new-b, I'll ask here. After paying for smoke check, and replacing the gas cap (duh) and the canister vent valve, the light came right back on. Anyone have a similar problem and/or common areas to look for? Thanks! Norm

Share this post


Link to post
Share on other sites

All right, maybe this has been discussed here before, but as a new-b, I'll ask here. After paying for smoke check, and replacing the gas cap (duh) and the canister vent valve, the light came right back on. Anyone have a similar problem and/or common areas to look for? Thanks! Norm

Check for a gas tank leak at or near the seam. If tank was full when the smoke test was done, it won't be caught. Look for wet spots/gas smell.

73's KC2UAB

Share this post


Link to post
Share on other sites

If you're getting the gas cap light and the CEL I would check for a problem with the evaporative emissions control system. The vac hose might have a leak.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.