Jump to content

craigtussey

Registered Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About craigtussey

  • Rank
    Newbie

Profile Information

  • Actual Name
    Craig Tussey
  • Gender
    Male
  • Location
    Richmond, KY
  • Chapter
    Not Enrolled

Car Information

  • My Car
    1989 Ford Taurus SHO
  • Engine
    3.0L, 182CID
  1. A code suggested that the MAF needed to be replaced.
  2. Hello, I have an 89' sho. I got it in 1990 with about 10000 miles on it. It has about 150K now. I work out of my home and am sort of local in my driving. I drive the car daily at least a little and drive easy. I'm 68 years old.I have 2 problems that may have been there for awhile, but have gotten worse. Problem 1 is a weak start. I turn the key and it starts weak and stutters a little in the low RPM range and then recovers to the normal tack (8900) setpoint. If I try to go before the car warms up, it will die and require that I push the accelerator to floor to start it, but it does start. When the car has warmed up, it runs OK. Problem 2 is that while it runs OK, there has been a major loss in power. The top speed is maybe 80MPH down hill with a tail wind. When I go up a hill in 4th, I can lose 10 MPH. The gas mileage is also real bad. MAF, plugs and wires, and O2 sensors are new. Any help will be appreciated. The car is in good shape in and out. I do a little restoring about every 5 years and this is a 5th year. I'm hoping to get another 50K out of this car. Please help.Thanks,craig tussey Any help will be appreciated. The car is in good shape in and out. I do a little restoring about every 5 years and this is a 5th year. I'm hoping to get another 50K out of this car. Please help.Thanks,craig tussey
×