Jump to content

daveromanjr

Centennial Member
  • Content Count

    464
  • Joined

  • Last visited

  • Days Won

    17

Everything posted by daveromanjr

  1. See? And everybody always thinks I'm full of s**t... Thank you Matt
  2. Any links that go through google (if you get a Google Hangouts message with a link to this site) are doing this. I've learned to copy and paste links when using my work computer.
  3. Same here ... when I look up a link to this site it sometimes goes to adultfriendfinder.com I know I'm not well liked here but that seemed cruel for when I'm at work.
  4. I'm 5'11" or so and I'm what the French call "fat"... I've never had a problem in a Fiesta.
  5. Thanks everyone! The chrome was aftermarket on this car. I like the chrome at the bottom of the doors and the chrome around the windows is growing on me. So far the radio has been good, the CD changer didn't have a magazine in it and the owner was surprised it had a changer in it so I'm thinking it hasn't been used during their ownership since 7000 miles. Hopefully it'll still work. It did have a busted passenger front spring, it is getting both front springs replaced. Next year I'll tackle the rear park assist, repair the aftermarket chrome and also keep my eye peeled for the release latch that I broke on the driver's door cubby. They're ~$80 online so hopefully I can find one cheap in a yard sometime soon. Oh, and a new "R" so I'm not driving a Town Ca.
  6. Ever since I was a little kid I've wanted a nice, big Town Car. The needlessly large, overly luxurious sedan is unlike anything else on the road but I just couldn't justify buying a rear wheel drive car while having to deal with snow where I live. In February I got a 2012 Escape Limited and a while back I was keeping an eye on Craigslist for some sort of Panther to show up that would be worthwhile. What I came up with is this, a 2003 Lincoln Town Car Signature. Has a moonroof and CD changer, I think that's pretty much about it option wise. 63k on the clock, it was built and sold in Canada but shortly thereafter it came to the states and at 7000 miles was sold to the 2nd owner. He had it for a while until he passed away and then his son had it. He was selling it just because they have too many (8!) cars. As with any used car there are a couple nitpicky issues. The stick-on chrome on the bottom part of the doors on the passenger side must've gotten tapped with something as it sticks out a bit. Its still secure but it'll probably get replaced. The rear park assist works here and there, that seems to be a common problem with this car. The parking brake needs adjusted. There are a couple cosmetic issues but they're very minor.... oh and I busted the driver's door cubby button. It still works but slides out when the cubby is open so I just have to be careful. Drives fantastic, shifts great, rides amazing. For what I paid I got one hell of a good car that needs relatively no work at all! Well minus the missing "R" in the TOWN CAR emblem. Somehow I'll learn to live without until I find a replacement R. I went out to get some pictures tonight, here are a few... I can't remember if I posted anything about my Escape. I haven't had a chance to get pictures of the Escape and Town Car together, but I have to admit they make a nice fleet for my driveway.
  7. That's a correct Centennial steering wheel. Then again, it has the badges in the wrong spot on the trunk.
  8. You shouldn't have to change out your wheel controls. The nav with sync system uses the same wheel controls that you currently have. I would say get a programed sync module and it'll work. I bet car-part or a junkyard is the best. You just need to get the right pin out because there was a weird change between 08-09. You would be better off finding an 09 module.
  9. Anthony and I installed Sync in his Milan with the same kit. The reason the HMI isn't working is because your sync module needs programed by a Ford dealer to function. We ran into the same road block, Ford dealers said that they wouldn't program it for us... maybe because we did the install ourselves? Anyway, to circumvent this we got a sync module out of a Focus at a junk yard for like $15 and it was plug and play. Since the focus one was already programmed it worked as soon as it was plugged in so that may be all you need to do. Sent from my SCH-I545 using Tapatalk
  10. I saw that ... it is like 10 minutes from my house. Weird Sent from my SCH-I545 using Tapatalk
  11. Another odd thing with the Focus (and also the current gen Escape) is that, like most other cars nowadays it has the ability to automatically turn on the headlights when the wipers are on. But they only turn on if the wipers are on Low or High. If you have them on intermittent the headlights won't turn on. All other cars I've had with the headlights that turn on with the wipers (continental, mkz, fusion, 2012 Escape) have them turn on regardless of wiper speed. But with the new focus-based escape and current focus it's just on low and high which doesn't make sense as it should he at any speed of wiper use that your headlights should come on according to the laws. Sent from my SCH-I545 using Tapatalk
  12. Should've just stayed here! Sent from my SCH-I545 using Tapatalk
  13. Hey my old sport rims live on. Sent from my SCH-I545 using Tapatalk
  14. Shoot me a pm I'll run it Sent from my SCH-I545 using Tapatalk
  15. Oh god where to begin... Sent from my iPad using Tapatalk
  16. I wonder if the Crown Vic didn't make the list because people tend to hold on to them until the wheels fall off instead of selling them... Sent from my iPad using Tapatalk
×
×
  • Create New...