Jump to content

Welcome to Taurus & Sable Owners' Club

Welcome to Taurus & Sable Owners' Club!
If you are not a member, registering to our forum is easy! To get immediate access to everything we have to offer, click here to register and get started! If you're already a memeber, sign in here.

Registering gives you access to:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • List your car in the Garage for everybody to see your car and it's mods
  • Get your own profile and make new friends
  • Buy and sell parts in the Marketplace
  • Take part in the car meets and events each year
  • And much more!
Guest Message © 2014 DevFuse

Gas Cap/check Engine Light On


  • Please log in to reply
2 replies to this topic

#1 NORM_K7NCR

NORM_K7NCR

    Newbie

  • Members
  • 8 posts
  • Location:KALISPELL, MT
  • TSOC Chapter:Not Enrolled
  • My Car:03 TAURUS SE FLEET
  • Engine:3.0 VULCAN


Users Awards

Posted 27 April 2011 - 04:50 PM

All right, maybe this has been discussed here before, but as a new-b, I'll ask here. After paying for smoke check, and replacing the gas cap (duh) and the canister vent valve, the light came right back on. Anyone have a similar problem and/or common areas to look for? Thanks! Norm
NORM K7NCR ---- "NOT RACIST, NOT VIOLENT, JUST NOT SILENT ANY MORE!"

#2 drjkel

drjkel

    Newbie

  • Members
  • 4 posts
  • Location:WNY
  • TSOC Chapter:Not Enrolled
  • My Car:2002 SEL
  • Engine:Duratec

Posted 30 May 2011 - 04:25 PM

All right, maybe this has been discussed here before, but as a new-b, I'll ask here. After paying for smoke check, and replacing the gas cap (duh) and the canister vent valve, the light came right back on. Anyone have a similar problem and/or common areas to look for? Thanks! Norm


Check for a gas tank leak at or near the seam. If tank was full when the smoke test was done, it won't be caught. Look for wet spots/gas smell.

73's KC2UAB
2002 Duratec SEL sedan - 170,000 miles
2000 Duratec SEL sedan - Died of rust at 115,000 miles in 2009
1993 Vulcan LX sedan - sold after 11 years of driving and 189,000 miles in 2004

#3 Angrod

Angrod

    I ain't no butt snatcher.

  • Platinum Members
  • 896 posts
  • Location:Clairton, PA
  • TSOC Chapter:Mid-Atlantic
  • TCCA Name:darth_v8er_dude
  • My Car:'04 Taurus SES
  • Engine:3.0 Vulcan


Users Awards

Posted 30 May 2011 - 08:33 PM

If you're getting the gas cap light and the CEL I would check for a problem with the evaporative emissions control system. The vac hose might have a leak.
Posted Image
Matt B.

Shosource UDP
removed indefinitely | Sonic DOOF audio system




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users